You NEED to Update Google Chrome ASAP

According to Google, hackers are currently exploiting a vulnerability found in the Google Chrome Browser. They have recommended that you update your version of Google Chrome ASAP to ensure you are secure. Any version of Chrome before version 72.0.3626.121 should be updated right away.

Google has made an effort not to disclose what the bug is or how hackers are exploiting it. This is done to ensure that other bad-actors don’t begin exploiting it too. However, Google has notified users and urgently pushed a patch to resolve the bug.

While there is little currently known about the threat, Justin Schuh, a Google Security Engineer tweeted out a more detailed write-up:

To check which version of Google Chrome you’re running and if an update is necessary, you’ll want to follow these steps:

First, click the three vertical dots in the top right of your browser. Then toward the bottom, hover your mouse over Help and click About Google Chrome.

Next, a new page should load that looks something like this

Lastly, you’ll want to make sure that you’re running the 72.0.3626.121 version. If you are not, update right away to ensure you’re secure.

Don’t forget to follow us on Twitter and Instagram to stay up-to-date with all things ALB!

About the author

Amateur blogger, avid gym goer, full time nerd and Owner of ALB. All thoughts are my own and they're amazing.

Leave a Reply

%d bloggers like this: